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Questions about the operations with images 

 

How to open several images at once? 

There are several ways to open a group of images. You may open them using the files open dialog, select images 
and press Open button. You may also select the images of interest with the left mouse button with pressed Ctrl key 
in the Manager panel list, open the context menu with the right mouse button and select Open command. 

What is the maximum size of the image that can be opened by ScanMagic application? 

ScanMagic application, thanks to its on-the-fly data spooling technology, enables to open and to work with images of 
any size. However, for some formats there are restrictions of the supported maximum image size. 

How can an image be converted from one format into another? 

There are several ways to change the image format. You may use Raster Converter or just open the image and then 
save it to the required format. 

How can the image quicklook be created? 

Open the image, perform zooming and contrasting and save it with Save View As function into a required format, 
e.g. in jpg. 

What is the difference between Save Image As  and Save View As options? 

In Save Image As mode the image is exported “as is”. i.e. with input set of channels, input radiometric resolution 
and contrast. In Save View As mode the image is exported with the current image view window display parameters, 
i.e. with current color synthesis (RGB) or channels (Grayscale), with current scale and contrast, with radiometric 
resolution of 8 bits per pixel.  

How to make and indexed image with own palette? 

You need to open the image of interest, go to View tab, activate Index Color radio-button and set up the number of 
spectral channel for visualization. The assign the palette to the selected channel, create the palette in the appearing 
Color Table dialog, select from the existing or load one via Load button. Specify the palette name with .pal extension 
in the appearing palette selection window and press OK.  

How can DEM and terrain image be colored? 

You need to open DEM image, in View tab activate Index Color radio-button and select the number of spectral 
channel for visualization. To set up a palette, press palette selection button and in the appearing Color Table dialog 
specify the palette of interest from the list or load your own palette. After that press OK.  
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How can image segmentation results be visualized? 

Segmentation results are saved to the first «Band1» channel of the image. To visualize the segmentation result, use 
the index color mode by activating Index Color radio-button with the default «Band1» channel. In Color Table dialog, 
select Segmentation or any other suitable palette in the opening list of palettes. 

Can the image, used to create a Region, be contrasted? 

Yes. To do so, select the name of the image being contrasted in SubImage control element and use image 
visualization and display elements of the View panel to set up contrasting parameters. Pay attention that when 
Region line is selected in SubImage control element, the actions via toolbar extend to the entire image of the Region, 
whereas if the name of one of the images is selected, the actions are limited to this image only. 

How can the RGB image be received from single-channel files of the image (e.g. Landsat)? 

Open all single-channel files in the program and create mosaic from these single-file images, assigning the channel of 
one of the input images to each mosaic’s channel.  

How can the spatial resolution of the color image be improved? 

Open the color image and the matching panchromatic image of higher resolution. Create Region, specifying the 
mosaic type Synthesis From Multiple-Band Image and setting up 4 output channels (three for color image and one 
for pan). Keep in mind, which Region channel has the pan image channel assigned to, and press Apply. After 
creating Region, check Resolution Merge box in View panel and enter the number of the pan image channel.  

No transformation into UTM zone. What can be the reason? 

UTM projection is a zonal projection, therefore make sure that the projection zones are selected correctly or select 
Autoselect option when transforming the image, which will automatically define the UTM zone, where the image is 
located.. 

What is the scattergram of pixel digital number? 

Scattergram of pixel digital numbers - is the graph, which x-axis is used to specify pixel DN values of the first image 
channel selected for analysis, whereas the y-axis – of the second channel. Basically, it is a diagram of dispersion of pixel 
digital numbers of two channels being analyzed. 

 

Questions about operations with vector maps 

 

How can a new vector map be created? 

Open the image and move to Vector panel. In Vector Editor group of elements press «Start vector layer editing». 
Vector layer type selection dialog will open. After selecting a vector map type, press «Create object», then create the 
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vector objects on the image, plotting points in the areas of interest on the image. Complete vector objects creation 
with the right mouse button click on the last point. After plotting all vector objects on the image, press «Stop vector 
layer editing». In the appearing file save dialog name the new vector map and press «Save». 

How can a vector map be edited? 

Open the image, put the vector map of interest on it and select this vector map in the list on Vector panel. In Vector 
Editor group of elements press «Start vector layer editing», then start editing the map’s vector objects. After editing 
completion, press «Stop vector layer editing». In the appearing file save dialog select «Save» and save the vector 
map. 

Why during editing of vector maps, vector objects’ coordinates are rounded off? 

If maps of a higher resolution are overlaid on a lower resolution image, then vector objects’ coordinates of this map 
are rounded off to the resolution of the image. Therefore, if it is required to edit a vector map as a whole, saving 
input details and accuracy of all objects, create Region to the entire territory with high resolution (matching the 
precision of the map’s coordinates), then put the vector map on this Region, edit it and save under a different name. 

How can a vector map fragment be cut out? 

You may use vector converter, which dialog can be opened via Tools -> Vector Converter menu. In the dialog 
window, add the vector map of interest to the list of input files, checking Cut Segment box and specify boundaries 
(X, Y) of the fragment being cut out. Press Convert button. 

 

Questions about operations with catalog tools 

 

What cataloguing tools may be needed for? 

If one of your tasks is to work with a big number of images, cataloguing tools, available in the application, enable 
you to easily create image catalogs and to quickly search for images using attributes. In addition, application allows 
the user to work with catalogs, located on other servers, as well as to export/import metadata. 

How can a record about the image be saved to the catalog? 

There are two options to save a record to catalog. You may open the image and select File-> Add to Catalog menu 
item. A form for adding records to catalog will open. Enter the information about the image and press Save Record. 
To add information about image, represented in form of a list in Manager panel, select the images of interest, press 
right mouse button and in the context menu select Add to Catalog. A form for adding records to catalog will open. 
There are also ways to quickly add images into the current database. For this to do, select Fast Add to Catalog in the 
context menu. 
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How can a new database for the catalog be created? 

After opening the form of adding records to catalog, you may enter the name of the new database into Database 
field and press Save Record. The application will show up a dialog to confirm the new database creation. Press OK to 
save the record of interest into the new database. 

How to select records about non-geolocated images? 

Go to Catalog panel and specify the database, where you will start to select from in Database field. In Geolocated 
drop-down list select No. Press Search. 

When working with catalog, there is a possibility to save the image dump. What is this? 

Image dump is a set of files, containing information about this image: metadata file with inf extension, quicklook of 
the image in jpg format. Shape-file in ESRI SHP format, projection file in prj format and quicklook of the map with 
image boundaries in png format. These files are created in a separate folder of the directory, specified by the user. 

 
How to move through the records, selected for putting into the catalog and editing? 

You may use Next Image and Prev. Image buttons to move through the records in the form for records addition to 
catalog and Next Record and Prev. Record buttons to browse the records in edition mode. You may also use the 
slider, located over the indicated buttons. The number to the left of the slider shows the index number of the current 
record in the group of records. 

Why during catalog editing quicklook and the shape-file are not added? 

If initially when the record was added to catalog, the quicklook and ESRI shape-file were not saved, than the 
quicklook and the map with plotted image boundaries will also not be added if checked when the record is being 
edited.  

What should be done to work with databases, located on other PC? 

You need to set up the remote server. For this to do, open File-> Options, go to Catalog tab and press Add Server. 
In the appearing dialog of server addition, specify the server parameters and press Add. After adding a new record 
to the list of available servers, select it and press Set Default. Catalog panel will display databases of the specified 
server. 

How can the data of the catalog, I have created, be transferred to the users? 

There several ways to transfer catalog data to the users. You may create Dumps of the images of the catalog of 
interest and send them to the users. Besides, you may use Export Catalog option, specifying the name of the catalog 
and the directory to save it. The received data may also be transferred to the users, who in their turn should use 
Import Catalog option to import the catalog to their application. 
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Questions about operations with geolocation and ground control points 

 

How to identify, if the image is geolocated or not? 

There are several ways to find, if the image is geolocated or not. If the icon of the image window is in form of a 
page with the globe, the image is geolocated. If the icon is in the form of a blank page – the image is not 
geolocated. Besides, the info about geolocation of the open image can be found in Geo tab. If the Simple Image 
radio-button is activated, the opened image is not geolocated. If Geolocated Image is activated – the image is 
geolocated. Geolocation can also be detected by moving the mouse pointer along the image field: if it is geolocated, 
Info tab will display geographic coordinates on-line. 

How can geolocation be corrected? 

Geolocation can be corrected using Geo tab, which elements enable to recalculate parameters of the used 
mathematic geolocation model. To do so,  you will need to overlay a vector map over the image and check 
geolocation quality while changing parameters. For RS data that are geolocated based on math models, describing 
relocation and satellite attitudes, a handy Geo Pan tool is available. This tool enables to match the map against the 
image with calculation of geolocation model parameters. 

How can I learn from the image which part of the globe is shown? 

If the image is geolocated, there are the following ways to find it. You may open Manager panel and Region window 
with overlaid vector maps of administrative boundaries of the countries and coastal lines and open the folder the 
image of interest. All geolocated images will be displayed in Region window as coverage contour lines. If the image 
of interest is selected from the list, it will be highlighted in red in Region window and you will detect immediately 
what is the location of this image. You may open the image of interest and in Info panel find geographic coordinates 
of the image. Or use World Map tab of Navigator panel.  

Why during the image export into one of the formats its geolocation is lost? 

If the image is geolocated, the location can be lost, if the image is saved in a format not meant for storing map 
projection parameters. To save image geolocation select proper formats, such as GeoTIFF. 

How can I recalculate coordinates from one projection into another? 

You need to use Coordinates Converter, which dialog can be opened via Tools -> Coordinates Converter. In the 
dialog window specify input and output projection parameters and load or manually enter coordinates values. For 
recalculation, press Convert button. Recalculated coordinate values will be displayed in the list of output coordinates. 

How can the “image-to-image” geolocation be carried out? 

Open the image which needs to be geolocated and the reference image. Pick up control points using elements on 
GCP panel and refresh geolocation (Image->Refresh Geolocation). Now you can transform input image into a map 
projection and its geolocation will be corrected with due account for set up control points. 
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How can the “Image-to-map” geolocation be carried out? 

There are two options. You may open the initial image and any geolocated image with overlaid map. Pick up control 
points using GCP panel. When the image is transformed into the required map projection, its geolocation will be 
corrected with due account for these GCPs. The other option is to place the initial image in Region and overlay a 
vector map. In this case control points will be picked up in one Region window. In this case press Refresh 
Geolocation after picking up GCPs. 

How can a list of GCPs be created without having vector maps and other images available? 

You may use Global Maps mosaic coverage. Open the image and Global Maps window for the area of interest. Use 
GCP panel, pick up control points from the image in Global Maps window, working with it as with usual geolocated 
image. 

 

Questions about operations with map services 

 

What map service can be used for? 

Map services, allowing access to multi-terabyte global coverages, can be used as sources of base maps, for example 
if vector maps are not available for a certain area. Besides, an easy way to move between different map services is 
available in the application. Such services are combined in one window, where they can be used as common large 
images. 

What needs to be done to display the area of interest in Global Maps window? 

You need to open Global Maps by pressing the button having the same name on the toolbar. Then open Navigate in 
Global panel.  In the appearing dialog specify the coordinates of the area of interest and press Go. For minor image 
relocations in Global Maps window, you may use the group of buttons Pan (Left, Right, Up, Down). 
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